1 Reply Latest reply on Jul 1, 2018 9:51 AM by mac9

    Battlefield 1 unplayable with RX480

    vocandin

      Got a brand new RX480 and Battlefield is unplayable, doesn't matter if graphics are all on low or all on ultra, in less than 5 minutes it freezes and I have to kill the process, plus the drivers crash and not always recover.

       

      I've tried these drivers and got these results:

      16.12.2 and 16.12.1: Game crashes and gives me the "DirectX Function Error"

      16.11.5: Game freezes, have to kill the process.

       

      I did try other drivers but they basically fall into those 2 categories above.

       

      Plus before I got the RX480, battlefield was running well enough with a GTX 760, even though everything was set to low, I was getting 30-40 FPS most of the time.

       

      I also tried other heavy tasks like Witcher 3 on max settings and Heaven Benchmark and everything works fine. Also tried: fresh windows install + fresh BF1 install, 1 screen instead of 2, vsync on, vsync off, frame capping to 50 fps instead of 60, using DDU on each driver uninstall in safe mode.

       

      Any ideas when a new driver is gonna be released? or If I missed an old driver that is stable on battlefield 1? Any help is appreciated.

       

      My system specs:

      CPU: i5 4460 @ 3.20 GHz

      CPU Cooler: Corsair Hyper 212 Evo

      Motherboard: Asus B85M-E

      Memory: HyperX Fury 2x4GB 1600mhz

      PSU: Corsair RM650i

      Graphics Card: Sapphire Nitro+ RX 480 OC

      Monitor 1: Acer S240HL on HDMI (1920x1080@60Hz)

      Monitor 2: Viewsonic VX2370 on HDMI (1920x1080@60Hz)

      SSD: Crucial MX300 750 GB

        • Re: Battlefield 1 unplayable with RX480
          mac9

          As you know there's been many updates, since your post... However this worked for me:

           

          Re-boot computer into Safe-Mode. Open the Device Manager -> Display Adapters -> Find your graphics card and DELETE the driver. To do that Properties->Driver TAB, Uninstall Device. On the uninstall device window that opens -> check the DELETE this driver box and click uninstall... Reboot, install newer drivers and hey presto issue gone !!!!