AnsweredAssumed Answered

Vista 32bit drivers radeon hd 6570

Question asked by jenj on Mar 17, 2016
Latest reply on Mar 17, 2016 by jenj

I have an 8 or 9 yr old dell xps 420. Over the years I've upgraded some parts. A while back the c-drive died, so I formatted the newer d-drive. Re-istalled windows vista 32-bit on it as C. And added a new 3tb drive as d.





But now I've run in to a problem... I cant seem to find the vista 32-bit drivers for my radeon hd 6570.





Through the site I found the catalyst center I always used. And it came with drivers for a lot of radeon hd models. (going by xps desktop resources) But the 6570 is NOT LISTED among them.





Installing catalyst has done something. (Hardware in computer management went from showing stock vga adapter to radeon hd 6570. And the hd tv i have connected as second screen was detected...)

But it seems to have problems, executing a lot of settings, I used to change with ease.






Switching resolution of scr1 back and forth between 1680x1050 and 800x600 works just fine. But if I select 1280x960, my screen blinks. And just sticks to the current resolution...





I thought I had downloaded the wrong drivers. Doing it manually, on the amd site. So tried the auto detect program...


"Intel core2 quad cpu q6600 @ 2.4ghz

Amd radeon hd 6570

Windows vista 32-bit



We were unable to find drivers for your system. Possibly your system isnt supported"





???How can that be??? It has worked just fine for years... With drivers for hd6***... How can I get it back to working, like before???



Tnx in advance for all your help...








Maybe should add that ive spend 5 evenings to get to this point...

Did my best to get good advise before buying the new hard drive. But seems that none of them were aware, of the limitations of old uefi biosses and vista 32bit...



Seeing I mostly have had to figured out the whole,  raid/sata, mbr/gpt, boot stuff by myself. It is entirely possible I messed something up, along the way. Causing this new problem, myself...



If so... Just blame it on me being blonde