AnsweredAssumed Answered

FFXIV Directx 11 issues still not fixed w/ latest drivers (R9-380)

Question asked by ebonclaw on Nov 19, 2015

It occurred to me that I should probably post this in the support forums- I've already posted about it in Red Team as I felt that as this was gaming related it might get a better response there, but it certainly won't hurt to put it here too, as this issue needs some exposure since it was deemed "resolved" earlier, but is actually still impacting multiple users.


Hey guys, I've spent the last two days bashing my head against a wall in an effort to remedy this problem that's affecting one of the rigs I posted earlier, and I've run out of options that I can think of.  The PC my wife and I built was created this year for more than a few reasons, but the main reason stemmed from the desire to have a better gaming experience with Final Fantasy FFXIV, as playing it on console, frankly, sucks.

Here's the build with specs for those of you who haven't seen it:  The Brave Little Toaster   (Short version; FX-8350, Asrock 970m Pro 3 mobo, Sapphire R9-380, 8GB RAM, Win 10)

Anyway, Final Fantasy's DX11 client had some problems crashing and burning on AMD and Nvidia cards for a while.  No biggie, we were told fixes would be in the works and that the latest drivers would remedy the situation, just play with the DirectX 9 client for a while.  Which works fine.

Fast forward to the deployment of patch 3.1 for the Heavensward expansion.  It happens to drop on the SAME day Fallout 4 comes out, so we're both a little sidetracked playing Fallout, but we also crossed our fingers that patch 3.1 would solve the DX11 issues.

Two or three days ago, we discovered that not only does patch 3.1 not solve the problem, it also removes the option to run the game in DX9 (receiving a "Please install latest version of DirectX when attempting to run the DX9 client) and forces players to move to the DX11 client.  This means that now my wife can't play.  At all.  Well, she can, just in 2-5 minute increments before a crash occurs, which is completely at random.  Sometimes when fighting, sometimes when walking around, and in both high and low traffic areas.


So now I actually have to figure out if there's anything I can do to fix it.  Here's a list of things I've tried.


Updated video card drivers to latest version.

Disabled tessalation in both the game and CCC

Turned off ambient occlusion

Switched around between windowed, borderless windowed, and fullscreen modes

Turned off high texture long distance rendering

Disabled rendering of non-visible objects

Reinstalled visual C++ libraries

Reinstalled directx

Set AA to 4x

Video card/system thermals are fine.


Things I haven't tried:

Significantly older drivers (the driver sets before the latest release didn't run the DX11 client either, I have zero reason to think going back even farther would have any different effect, if they were even Windows 10 compatible)

Reinstalling FFXIV (This is a mega huge download, multi hour process that has zero instances of it resolving this specific issue from those that have tried it)


Lastly, please note, I'm in IT and this PC is used almost expressly for gaming.  It's a clean system from a malware/virus standpoint, with a pretty fresh windows install, I guarantee it.



And here's screenshots of the error details in event viewer:


When the crash occurs, the game freezes (though game audio usually continues) and I usually have to get back to the desktop with ctrl alt delete, where I have a message waiting for me from windows that the display driver stopped working and recovered.  FXIV is the ONLY game on the system that is experiencing problems


In the research I've done, I've stumbled across one or two instances of allegations that these problems are rather specific to Tonga based GPUs: 

FFXIV Heavensward dx11 client game crash w/ R9 285

There's more, but I won't both flooding this post with them.

Anyway, the problem has been acknowledged (to some extent) by SE, AMD, and Nvidia, and allegedly addressed:
Final Fantasy XIV - Heavensward may crash when run in DirectX 11 mode and borderless window mode ,r9 380 driver 15.11 beta  still cash win 10  ,direct x error 11000002

However, it would appear that while the new drivers have solved the crashing for some users, Tonga based GPU users still seem to be affected.  Please note that my system setup(Project Blackout (Define R4/FX-8370) ) using an R9-280 with the SAME driver set has ZERO problems and has ALWAYS been able to run the DX11 client (even before the latest update).


After everything I've done over the last few days, and research included, I'm not entirely sure who should claim ownership of this issue.  While it would appear that the only people still affected are Tonga based GPU users, FFXIV also appears to be the only game really causing problems with them at this point.  The fact that Nvidia users also got hit with this makes me want to go after SE, but the fact that this issue seems to be resolved enough the SE felt it was ok to take away the DX-9 client while a specific series of AMD cards is having issues makes me want to bring it to AMD's attention, as this subest of cards seems to be the only ones still having problems.  Before doing all that, I figured I would bring it here first to see if anyone else has some bright ideas.  Honestly, I'd rather bring it to AMD's attention anyway because their customer support has a reputation for being far superior to that of SE's US based support.

Side notes:  I have not attempted a reinstall of the game.  It is an enormous download that takes a few hours, and I've read that this has solved the issue for exactly 0% of users.

My wife has suddenly found herself with a game she's sunk countless hours into, as a few hundred bucks between the game, expansions, and subscription fees (plus the fact that I had to buy the game all over again to get a PC license when we moved her from the PS4) that she can't play.  I gotta get this fixed and I really, really, really don't want to have to buy a new GPU after less than a year to resolve this issue; I shouldn't have to and my budget is just about exhausted anyway after completing my upgrades last month.