15 Replies Latest reply on Aug 17, 2015 4:50 PM by dorono

    Few problems with new release 1.5.6571.0


      - Debugger still does not work for me, it locks up Visual Studio, CodeXL crashes inside clBuildProgram. The same program runs fine normally. I read somewhere that the previous version had problems with the latest radeon drivers, is it still the case?

      - Visual Studio 2013 integration can hardly scroll any views, they only update in every 10 seconds, completely unusable.

      - Could not send the crash report of CodeXL, not using proxy.

        • Re: Few problems with new release 1.5.6571.0

          Hi gabest,

          Which driver release are you working with? CodeXL 1.5 supports driver releases up to 14.10 and from 14.30 (unreleased yet) onward. If you're using driver 14.20 (bundled in Catalyst 14.7) then Kernel Debugging will not work.

          Visual Studio 2013 performs a registration step of the CodeXL extension after the CodeXL installation is complete. This may take a few steps and slows down the PC considerably. Can you try CodeXL inside VS2013 again? What type of file are you scrolling?

          Can you attach the crash report? Or send it to gputools.support@amd.com?

          1 of 1 people found this helpful
            • Re: Few problems with new release 1.5.6571.0

              Just installed it again, after putting back the old version temporarily, and visual studio fixed itself.


              I am using 14.7, the beta, going to try it with the non-beta in a minute.


              Update: Had to reinstall codexl again, visual studio kept closing itself without a trace after 10 seconds opening the project. But everything seems fine now, debugging works with the non-beta driver. I'm so happy, had to rely on printf for the first few weeks of my opencl adventures.

              • Re: Few problems with new release 1.5.6571.0


                Can you tell us when we will see "14.30 (unreleased yet) onward"



                • Re: Few problems with new release 1.5.6571.0

                  I'm also having trouble with the Visual Studio plugin views refreshing too slowly.


                  This is on VS2012 pro, in an Application Timeline Trace window, with a fresh installation of CodeXL 1.5.6571.0 . The issue persists even after restarting Visual Studio. Both the upper timeline view and the summary display below it exhibit this behaviour. The detailed popup on kernels in the timeline view flickers, even though I'm not moving my mouse at all.


                  Edit: CodeXL in stand-alone mode does not have the display refresh issues.

                    • Re: Few problems with new release 1.5.6571.0

                      It was said that those problems will be fixed in the new CodeXL release. Well they are not!

                      Can't debug because of access violations in clBuildProgram like the OP already mentioned. Profiling doesn't work because I immediatly get a bluescreen when the applications starts.


                      Please fix this and please don't let us wait for another scheduled release and just publish a fixed version.



                      - HD7850

                      - Windows 7 x64

                      - Latest (non beta) drivers installed

                        • Re: Few problems with new release 1.5.6571.0

                          Hi zish,

                          Not trying to dodge our responsibility for a robust CodeXL user experience, but crashes inside clBuildProgram indicate a problem in the OpenCL runtime or compiler, both of which are packaged in Catalyst and are unchanged by a CodeXL installation. CodeXL forces a few compilation flags to support kernel debugging. This is why a kernel may build properly when run outside CodeXL but cause a crash when run in a CodeXL debug session.

                          The AMD Developer Tools team works closely together with the OpenCL runtime and compiler teams to resolve these issues. However, to benefit from these fixes you have to install the Catalyst release that contains them.

                          The next Catalyst release is very near and I hope it will allow you to debug your kernels with CodeXL. Please let us know if it fails to do so.

                        • Re: Few problems with new release 1.5.6571.0

                          The view refresh bug still happens to me as well, only restarting visual studio fixes it.

                      • Re: Few problems with new release 1.5.6571.0

                        I'm having some issues with this version of CodeXL and Visual Studio too, just installed Catalyst Omega and I can debug kernels and everything, but, when I try to watch some variables like int4, float4, or lets say, view the content of a float4 p, p.x, Visual Studio lock down and only unlock closing the debugging program instance. This is very annoying, I'm actually stuck on a kernel because I can't debug it.

                          • Re: Few problems with new release 1.5.6571.0

                            Hi h_danilo,

                            Can you please provide more details:

                            Can you debug the same scenario with the CodeXL standalone application?

                            What version of Visual Studio are you using?

                            What OS?

                            Can you provide the kernel source code (possibly by email to gputools.support@amd.com if you don't want it posted on this public forum)?

                              • Re: Few problems with new release 1.5.6571.0

                                Hi dorono I can provice some informations to help you guys out, here are some:


                                I didnt try to debug with CodeXL standalone application since I lack skill with it.

                                Im using Visual Studio 2012 64 bits

                                What OS? Win 7 64 bits

                                The kernel code is:


                                1. __kernel void vglCl3dEqual(__read_only image3d_t img_input1,__read_only image3d_t img_input2, __global char* output)
                                2. {
                                3.     int4 coords = (int4)(get_global_id(0), get_global_id(1), get_global_id(2), 0);
                                4.     const sampler_t smp = CLK_NORMALIZED_COORDS_FALSE | //Natural coordinates
                                5.                               CLK_ADDRESS_CLAMP |           //Clamp to zeros
                                6.                               CLK_FILTER_NEAREST;           //Don't interpolate
                                7.     float4 p1 = read_imagef(img_input1, smp, coords);
                                8.     float4 p2 = read_imagef(img_input2, smp, coords);
                                9.     if (!(p1.x == p2.x))
                                10.     {
                                11.         output[0] = 1;
                                12.     }
                                13.     if (!(p1.y == p2.y))
                                14.     {
                                15.         output[0] = 1;
                                16.     }
                                17.     if (!(p1.z == p2.z))
                                18.     {
                                19.         output[0] = 1;
                                20.     }
                                21.     if (!(p1.w == p2.w))
                                22.     {
                                23.         output[0] = 1;
                                24.     }
                                25. }


                                Here I may also add something about the kernel functionality and another bug found here, but not regarding CodeXL, but OpenCL that comes with the new Catalyst Omega.


                                This kernel is made to check if two 3d images are equal(one way to check if some Image Processing algorithm have converged), before running the kernel, I set output[0] to 200, so if its 1 in the end the images are NOT equal. I tried to debug to see the data behind p1.x or p2.x, when I tried to "watch" those types of variables, the VS hangs until I close the application that is being debugged. Done some "blind" debugging because the way the comparison were supposed to happen were like this:


                                1. if (p1.x != p2.x)
                                2. {
                                3.   output[0] = 1;
                                4. }


                                But that wasnt working for some mysterious motive. So I checked if >, < and == were working and they were, but != for some reason werent. Then I changed it to (!(p1.x == p2.x) and BANG, it worked.


                                So here is two bugs reported:


                                1. CodeXL cant watch variables of type float4, int4, etc, like the float4 p1; p1.x

                                2. OpenCL that comes with new Catalyst Omega isnt working for operator != over two floats(or perhaps the problem is the float4 type).


                                That silly OpenCL problem made me lost about 2 hours because I couldnt believe that OpenCL != wasnt working.

                                That's all information that I have and hopefully that will help you guys fix those minor bugs!


                                If any further information is needed, just contact me again!

                                  • Re: Few problems with new release 1.5.6571.0


                                    I enqueued the kernel you provided from a sample program and could debug it inside VS2012 and watch its local variables successfully, on Win7-64.

                                    To present the debug info, CodeXL retrieves a lot of data from the debugged application. In extreme cases this may take some time - even more than a minute. Unfortunately, while CodeXL is collecting this data, the VS IDE is on hold, so lengthy operations cause VS to be unresponsive until the operation completes.

                                    What are the dimensions you use for the workgroup and the images? Also, what is the HW configuration you use: which CPU/GPU?

                                    Try reducing the dimensions of the images and workgroup.


                                    BTW, I assume when you wrote "VS2012 64 bit" that you're building your app as a 64-bit application. All Visual Studio IDEs are 32-bit applications.