• Wrong OpenCL calculation result on AMD 5700 XT

    Good day!   Our company uses OpenCL framework to work with AMD GPUs. But unfortunately, the OpenCL driver for AMD 5700 XT GPU gives wrong calculation results. This applies for all GPU drivers I have tested so fa...
    Neverhood
    last modified by Neverhood
  • OpenCL Shader compiler had memory allocation problem

    I'm trying to compile a rather large kernel and being give the following error after 20-40 sec of kernel compile time, both in the runtime as well as under CodeXL:   Shader compiler had memory allocation problem...
    glupescu
    last modified by glupescu
  • clinfo and rocminfo hang on navi gpu (5700XT)

    I am wondering if anyone got it to work to use 5700XT for opencl on a Linux host?    I installed ROCm 3.0.6 on a Ubuntu 16.04 host, but both clinfo and rocminfo hanged. I posted this question on R...
    FangQ
    last modified by FangQ
  • OpenCL driver causing heap-corruption?

    Hi,   we have a severe issue with OpenCL and I wonder if anyone else has a similar problem, if this is a known AMD driver issue or if we are doing something wrong. We are using AMD Radeon RX 570 and 580 GPUs wit...
    ruwen
    last modified by ruwen
  • OpenCL compiler crash

    Hi everyone.   When I try to compile OpenCL kernel on my notebook with Radeon HD 7340 GPU, I have segfault inside clBuildProgram function. If I comment line  b += (val << r[i]) | (val >> (...
    eltio
    last modified by eltio
  • OpenCL development documentation on AMD GPUs

    Is there a publicly available list of all AMD GPUs supporting OpenCL which includes: product name ('AMD Radeon RX Vega 64') internal name ('gfx900', can be obtained as CL_DEVICE_NAME) architecture ('GCN gen 5') ar...
    timchist
    last modified by timchist
  • How to access more then 32k byte shared memory on Vega & Navi using Windows?

    Hi all. Well the title already describes it. I have got a code using 64k LDS on a Radeon VII and a RX 5700. Work group size is 1024. Its working fine on Ubuntu 16.04 and 18.04 using amdgpu-pro 18.50, 19.30 and ROCm ...
    lolliedieb
    last modified by lolliedieb
  • Why did AMD decide to remove SPIR 1.2 support without adding SPIR-V?

    We have found, like many others, that the AMD GPU may report OpenCL 1.2 or even 2.0 support, with SPIR. However, that may not actually be the case. We're aware that you're looking into this, and will remove reported s...
    torbsorb
    last modified by torbsorb
  • Offline compilation for gfx1010 crashes

    When I try to compile any OpenCL source for gfx1010, the test application crashes in one of the AMD driver DLLs. Tested with Adrenalin 19.7.1 and 19.7.3 on Windows 10 and Windows 7.   That's a crash report I am...
    timchist
    last modified by timchist
  • ROCm OpenCL freezes when calling clCreateCommandQueue

    Hi Devs !   Can you Please have a look at this strange ROCm OpenCL DeadLock Run Time Bug here please !   https://community.amd.com/thread/245795   I have posted detailed GDB information and also clin...
    linuxperia
    last modified by linuxperia
  • Heterogeneous toolchain for Windows?

    Good day,   I am currently running windows with OpenCL kernels across CPU(2990WX) and AMD GPU with C++17.   As AMD stopped support for OpenCL on CPU how can I adapt my tool-chain to still leverage the CPU ...
    genestoltz
    last modified by genestoltz
  • OpenCL SDK

    Hello, I've been working on a parallel particle simulation using OpenCL. I've got to the point of writing documentation and need to link any potential users to the AMD OpenCL SDK. As per this thread and this thread, t...
    xorgon
    last modified by xorgon
  • OpenCL: "AMD HSA Code Object loading failed" in clBuildProgram on AMD Radeon RX 5700 XT

    Hi,   Developer of PTGui here (www.ptgui.com).   One of the users of my software has reported an error while building OpenCL kernels on a Radeon RX 5700 XT on Windows 10. clBuildProgram returns "AMD HSA Co...
    joostn
    last modified by joostn
  • Why not ship the latest OpenCL ICD Loader?

    In order to enumerate OpenCL platforms in a system, the ICD loader is usually the best option because it allows a platform independent way of having multiple OpenCL implementations in the same system.   The Rade...
    tluisrs
    last modified by tluisrs
  • AMD GPU OpenCL get wrong results while Nvidia correct

    Recently, I translated a CPU code into OpenCL, and it has been debugged and tested (using GTX1060). The calculating process of this code is an iteration process. The calculating results are presented in the form of re...
    huzhiyuan1994
    last modified by huzhiyuan1994
  • clGgetDeviceIDs suddenly very slow

    We are currently developing an OpenCL application on Windows 10 (Visual Studio 2017) but have noticed that the OpenCL performance has recently degraded, with the call to clGetDeviceIDs now taking around 10 second...
    andyste1
    last modified by andyste1
  • How to abort clEnqueueWaitSignalAmd?

    We're developing software that uses a PCI data acquisition card to read blocks of data (records) from an external instrument. These records are transferred to a Radeon Pro WX7100 using "DirectGma", where a kernel proc...
    andyste1
    last modified by andyste1
  • clLinkProgram crashes when trying to create program from bitcode file. An unhandled exception is thrown out from "amdocl12cl64.dll"

    I tried to create opencl program from bitcode file. I used clang to convert *.cl file to *.bc file by calling command clang -cc1 -emit-llvm-bc -triple spir64-unknown-unknown -cl-std=CL1.2 -cl-spir-compile-options "-c...
    cuijing
    last modified by cuijing
  • Any details about Wave32 mode for OpenCL?

    Hi, is there any parameter that I can pass to clBuildProgram to enable wave32 compilation? Or it doesnt exist as a thing and there some kind of Wave32/Wave64 mode to be enabled? I have found string GPU_ENABLE_WAVE32_M...
    andru
    last modified by andru
  • Why I can't use buffers with 4GB?

    Hi, I'm using OpenCL on Windows 10 and a Radeon RX580 card (8GB VRAM). I tried to allocate two buffers with 4GB to use in a kernel, but at this size, all I get is 0.0. I double checked address bits and it is 64 and th...
    nightz85
    last modified by nightz85