• Why not ship the latest OpenCL ICD Loader?

    In order to enumerate OpenCL platforms in a system, the ICD loader is usually the best option because it allows a platform independent way of having multiple OpenCL implementations in the same system.   The Rade...
    tluisrs
    last modified by tluisrs
  • clGgetDeviceIDs suddenly very slow

    We are currently developing an OpenCL application on Windows 10 (Visual Studio 2017) but have noticed that the OpenCL performance has recently degraded, with the call to clGetDeviceIDs now taking around 10 second...
    andyste1
    last modified by andyste1
  • Why did AMD decide to remove SPIR 1.2 support without adding SPIR-V?

    We have found, like many others, that the AMD GPU may report OpenCL 1.2 or even 2.0 support, with SPIR. However, that may not actually be the case. We're aware that you're looking into this, and will remove reported s...
    torbsorb
    last modified by torbsorb
  • OpenCL: "AMD HSA Code Object loading failed" in clBuildProgram on AMD Radeon RX 5700 XT

    Hi,   Developer of PTGui here (www.ptgui.com).   One of the users of my software has reported an error while building OpenCL kernels on a Radeon RX 5700 XT on Windows 10. clBuildProgram returns "AMD HSA Co...
    joostn
    last modified by joostn
  • Strange printf behaviour on Vega

    Tested on latest 19.10.1 drivers. Windows 10 x64 1903 I attached cl file and cpp program which would launch this simple addVec kernel. Opencl code: #pragma OPENCL EXTENSION cl_amd_printf : enable __attribute__((req...
    ___
    last modified by ___
  • Why I can't use buffers with 4GB?

    Hi, I'm using OpenCL on Windows 10 and a Radeon RX580 card (8GB VRAM). I tried to allocate two buffers with 4GB to use in a kernel, but at this size, all I get is 0.0. I double checked address bits and it is 64 and th...
    nightz85
    last modified by nightz85
  • Broken OpenCL drivers for RX5700

    Hello. I see many messages regarding wrong results that AMD RX 5700 cards producing. Those results are consistent (being WRONG) enough to pass statistical validation.   Why AMD being long-term and knowable corp...
    Raistmer
    last modified by Raistmer
  • Offline compilation for gfx1010 crashes

    When I try to compile any OpenCL source for gfx1010, the test application crashes in one of the AMD driver DLLs. Tested with Adrenalin 19.7.1 and 19.7.3 on Windows 10 and Windows 7.   That's a crash report I am...
    timchist
    last modified by timchist
  • Offline compilation for gfx906 not possible on a VM

    We used to compile our OpenCL code on a virtual machine without an AMD GPU by extracting all DLL files from AMD driver to a folder in PATH. This worked fine until at least Catalyst 17.8.2 and allowed us to compile bin...
    timchist
    last modified by timchist
  • What the error "HSAIL doesn't support OpenCL extension spir" means?

    I am trying to use SPIR in Windows with the latest AMD Adrenalin 19.5.2, but since I upgraded to the latest version I'm getting this error in the call to clBuildProgramWithBinary   Error: HSAIL doesn't support Op...
    tluisrs
    last modified by tluisrs
  • clEnqueueAcquireD3D11ObjectsKHR blocks for a long time

    In my application, I have a processing thread that enqueues an OpenCL kernel that writes to a ID3D11Texture2D object.   Everything works fine in terms of correctness. I can successfully acquire the shared O...
    elad
    last modified by elad
  • host-device latencies?

    Doing recently some benchmarks and wonder if my host-device latencies are bound to my older hardware or are similar on newer systems?   OS: Ubuntu 18.04 x86-64 Device: AMD Radeon HD 7750   OpenCL gpu kerne...
    smato2018
    last modified by smato2018
  • OpenCL: Delay in inter-kernel execution when requesting callbacks

    Hi I have a problem with delays in kernel execution when I request callbacks from OpenCL. In my application, I need to execute kernels at a "very" high rate (around 300Hz), and I need a callback to my host applicati...
    nfogh
    last modified by nfogh
  • How to pass a pointer to structure that contains a value in opencl

    I am trying to work on this code but everytime I gets runtime error "error: field may not be qualified with an address space global uint64_t external; Here is my data structure in hdr.h: typedef unsigned long uint64...
    avinashkrc
    last modified by avinashkrc
  • Optimizing data transfer with APU (best way to test zero-copy?)

    So finally I have got my APU test system (I paid for it!): -CPU: AMD Ryzen 5 2400G -MB: Asrock X470 Fatality Gaming mini-ITX -RAM: G.Skill 3200 C14, 16GB*2 -OS: Windows 10 Pro -IDE and compiler: Visual Studio 2017 Com...
    sandbo
    last modified by sandbo
  • SPIR support in new drivers lost

    I already ask this question in Drivers & Software section but nobody answer.   --------------------------------------------------------------------------------------------------------------------------------...
    ipse
    last modified by ipse
  • OpenCL CPU runtime

    Hi all,   Since AMD dropped support for OpenCL SDK, is there alternative option for OpenCL runtime on CPU? I'm well aware of GPU options, but seems like removal of SDK means also that there is no more CPU runtim...
    expro
    last modified by expro
  • Is there any way to split a compute device (emulate two, or more, GPUs on the a single device)?

    For example I have a RX Vega 64 with 64 CUs and 8 GB VRAM, would it be somehow possible to make it appear like two GPU compute devices with 32 CUs and 4 GB VRAM each? Maybe some undocumented environment variable for d...
    bomby
    last modified by bomby
  • Missing OpenCL CPU support under Windows

    On my system the (i think) most recent version of the AMD drivers (18.8.1, Windows 10 x64) no longer returns the CPU (FX-8350) as a valid OpenCL device.  Is this intended behavior or just a bug in my specific ins...
    pangea
    last modified by pangea
  • Memory-Leak at calling clBuildProgram with Radeon WX9100

    Running the Code below leads to massive main memory consumption by using Radeon WX9100 with driver Version 18.Q1. At iteration 1000 my program consumes about 1 GiByte Memory. I also tested the code with AMD FirePro ...
    recoguy
    last modified by recoguy