• CL-GL Interop fastest way to synchronize?

    We are using OpenCL on Windows as part of a proprietary game-engine where we use the CL-GL interop functionality to communicate between the simulation and the rendering engine. Our core loop currently executes the fol...
    george72
    last modified by george72
  • Is there any way to split a compute device (emulate two, or more, GPUs on the a single device)?

    For example I have a RX Vega 64 with 64 CUs and 8 GB VRAM, would it be somehow possible to make it appear like two GPU compute devices with 32 CUs and 4 GB VRAM each? Maybe some undocumented environment variable for d...
    bomby
    last modified by bomby
  • Strange behavior of a kernel, need fresh ideas

    I lost two days debugging or better to say tried to debug my kernel. Basically the kernel looks like this (part of dagger-hashimoto initialization):   1. copy from global to private 2. do private 3. copy from ...
    kbala
    last modified by kbala
  • Missing OpenCL CPU support under Windows

    On my system the (i think) most recent version of the AMD drivers (18.8.1, Windows 10 x64) no longer returns the CPU (FX-8350) as a valid OpenCL device.  Is this intended behavior or just a bug in my specific ins...
    pangea
    last modified by pangea
  • Memory-Leak at calling clBuildProgram with Radeon WX9100

    Running the Code below leads to massive main memory consumption by using Radeon WX9100 with driver Version 18.Q1. At iteration 1000 my program consumes about 1 GiByte Memory. I also tested the code with AMD FirePro ...
    recoguy
    last modified by recoguy
  • How to use llvm to offline compile .cl file into binary that can run with amdgpu pro driver?

    Now I am trying to build OpenCL kernel binary with llvm. I successfully compiled .cl into assembly, but cannot figure out a way to compile that format of assembly into binary that can run with AMDGPU pro driver. That ...
    fancyix
    last modified by fancyix
  • OpenCL linker hangs & terminates application on R9 200

    After shipping our application, some users with AMD R9 200 series cards report the application hangs up and then quits. After studying log files and minidumps it seems the issue is the with OpenCL linker on those syst...
    george72
    last modified by george72
  • E8860 do not  be identify in OpenCL

    Hi,      I have a X86 signal board computer(ADVANTECH MIC-6311,i7-4700EQ,HD Graphics 4600 ) and a E8860 GPU board.They are connected through PCIe.      My system is Win7 32bit...
    yyd1986
    last modified by yyd1986
  • OpenCL compiler crash with compound literals.

    The following code that uses compound literals causes the AMD OpenCL compiler to crash.   platform_version: OpenCL 2.0 AMD-APP (1800.8) platform_name: AMD Accelerated Parallel Processing device_name: AMD Radeo...
    Ono-Sendai
    last modified by Ono-Sendai
  • Three cheers for anonymous AMD engineer that fixed OpenCL driver bug

    My app makes very heavy use of OpenCL events. For the longest time, the app was unstable - seemingly there was a race condition where event callbacks sometimes would not get called, causing my app to stop working. ...
    boxerab
    last modified by boxerab
  • 64bit flat memory address -> buffer_load

    Hi,   I have a 64bit address, and it works well when I'm using flat_load_dword instructions. However I would like to use the advanced address calculation goodies of the old buffer_load_instruction.   My q...
    realhet
    last modified by realhet
  • LLVM ERROR:call to an undefined function "memset"

        Hello everyone, my programme crashes when I run it. The error message is title. The strange thing is I never use memset function in the kernel, but the error comes from clGetProgramBuildInfo。And whe...
    baifenghuang
    last modified by baifenghuang
  • Various CL faults with vega on windows...

    I have a 290X and vega64 in the same system, the v64 is the primary card, however in the context of openCL it's device '1', with the 290X being '0'. This is all running windows 10 pro 64 with the latest 18.3.4 drivers...
    paul17041993
    last modified by paul17041993
  • Bug in AMD driver

    Hello community,   First, about me: I'm a student from Germany. I am studying Computational Engineering and I write GPU-accelerated numerical software.   With the current AMD Radeon 18.2.1 drivers, there ...
    robin.christ@gmx.de
    last modified by robin.christ@gmx.de
  • CL_DEVICE_TOPOLOGY_AMD Is Broken with Latest Drivers. Please Fix ASAP!

    With Radeon Software Adrenaline 17.12.2, calls to clGetDeviceInfo with CL_DEVICE_TOPOLOGY_AMD always return wrong results. You can easily see this with clinfo:   Device Topology: PCI[ B#0, D#0, F#1 ]   The...
    meriken
    last modified by meriken
  • OpenCL -O2 makes program incorrect: Help!

    Hello AMD Forums,   This is my first post and I'm also new to OpenCL. Hopefully my mistake here isn't too "n00b". At the core, my program functions perfectly well at -O0 optimization level, but as soon as I go t...
    dragontamer
    last modified by dragontamer