• Why I can't use buffers with 4GB?

    Hi, I'm using OpenCL on Windows 10 and a Radeon RX580 card (8GB VRAM). I tried to allocate two buffers with 4GB to use in a kernel, but at this size, all I get is 0.0. I double checked address bits and it is 64 and th...
    nightz85
    last modified by nightz85
  • Offline compilation for gfx906 not possible on a VM

    We used to compile our OpenCL code on a virtual machine without an AMD GPU by extracting all DLL files from AMD driver to a folder in PATH. This worked fine until at least Catalyst 17.8.2 and allowed us to compile bin...
    timchist
    last modified by timchist
  • Why does device's opencl version using cl2.hpp shows a opencl 1.2 device while the SDK has opencl 2.0?

    when I get the cl::device info with CL_DEVICE_VERSION flag it shows I have a gpu compatible with opencl1.2 but it is in fact opencl 2.0 (the platform shows it is compatible with 2.1 and the Fiji has support for OpenCL...
    pontiacgtx*
    last modified by pontiacgtx*
  • Why not ship the latest OpenCL ICD Loader?

    In order to enumerate OpenCL platforms in a system, the ICD loader is usually the best option because it allows a platform independent way of having multiple OpenCL implementations in the same system.   The Rade...
    tluisrs
    last modified by tluisrs
  • What the error "HSAIL doesn't support OpenCL extension spir" means?

    I am trying to use SPIR in Windows with the latest AMD Adrenalin 19.5.2, but since I upgraded to the latest version I'm getting this error in the call to clBuildProgramWithBinary   Error: HSAIL doesn't support Op...
    tluisrs
    last modified by tluisrs
  • clEnqueueAcquireD3D11ObjectsKHR blocks for a long time

    In my application, I have a processing thread that enqueues an OpenCL kernel that writes to a ID3D11Texture2D object.   Everything works fine in terms of correctness. I can successfully acquire the shared O...
    elad
    last modified by elad
  • OpenCL compiler SIGSEGV'ing

    Hello!   So I've been writhing my OpenCL project until I run into a strange problem: a call to clBuildProgram results in a segmentation fault.   I'm providing a sample code here (see attached archive) that...
    be_dos
    last modified by be_dos
  • OpenCL 64 bit atomics under Vega 8 Integrated Graphics on Win10 ?

    I am working to compile an OpenCL program which needs 64bit atomics (atomic_xchg and atomic_add, with long datatype). I have added " #pragma OPENCL EXTENSION cl_khr_int64_base_atomics : enable" and the ...
    glupescu
    last modified by glupescu
  • OpenCL driver bug

    EDIT: reformat  EDIT 2: correct driver version   Found a weird behavior in AMD's OpenCL compiler. Code taken straight from Boost library:   __kernel void serial_adjacent_find(const uint size, __global...
    rosenrodt
    last modified by rosenrodt
  • OpenCL development for Radeon VII under Windows 7

    Hello!   Recently I've bought a Radeon VII for OpenCL development purposes.   I installed it in my dual-boot Windows 7 & Linux machine, and now I'm trying to setup a development environment.   My...
    be_dos
    last modified by be_dos
  • Error code -2 (Device not availaible) when running clCreateContextFromType

    Hello Everyone,   I'm currently retesting some OpenCL code and I recently had a problem on my code. When I'm trying to get the device list on my computer with the C++ Wrapper function ... I get a error...
    fyfy
    last modified by fyfy
  • OpenCL: Delay in inter-kernel execution when requesting callbacks

    Hi I have a problem with delays in kernel execution when I request callbacks from OpenCL. In my application, I need to execute kernels at a "very" high rate (around 300Hz), and I need a callback to my host applicati...
    nfogh
    last modified by nfogh
  • OpenCL compilation hangs forever

    Hi all,   I am trying to compile this project for an AMD GPU: GitHub - webmaster128/lisk-vanity: A tool to generate short Lisk addresses with GPU support   The c.l files are in lisk-vanity/src/opencl at m...
    webmaster128
    last modified by webmaster128
  • Optimizing data transfer with APU (best way to test zero-copy?)

    So finally I have got my APU test system (I paid for it!): -CPU: AMD Ryzen 5 2400G -MB: Asrock X470 Fatality Gaming mini-ITX -RAM: G.Skill 3200 C14, 16GB*2 -OS: Windows 10 Pro -IDE and compiler: Visual Studio 2017 Com...
    sandbo
    last modified by sandbo
  • SPIR support in new drivers lost

    I already ask this question in Drivers & Software section but nobody answer.   --------------------------------------------------------------------------------------------------------------------------------...
    ipse
    last modified by ipse
  • OpenCL amdgpu-pro generated code performance - please convert 'select' to cndmask

    Hi,   I don't know if this place is the best place to report opencl compiler performance issues, but well I didn't find a better place.   SUMMARY: Please AMD devs, when an OpenCL dev takes the time to expl...
    mannerov
    last modified by mannerov
  • CL-GL Interop fastest way to synchronize?

    We are using OpenCL on Windows as part of a proprietary game-engine where we use the CL-GL interop functionality to communicate between the simulation and the rendering engine. Our core loop currently executes the fol...
    george72
    last modified by george72
  • Is there any way to split a compute device (emulate two, or more, GPUs on the a single device)?

    For example I have a RX Vega 64 with 64 CUs and 8 GB VRAM, would it be somehow possible to make it appear like two GPU compute devices with 32 CUs and 4 GB VRAM each? Maybe some undocumented environment variable for d...
    bomby
    last modified by bomby
  • Strange behavior of a kernel, need fresh ideas

    I lost two days debugging or better to say tried to debug my kernel. Basically the kernel looks like this (part of dagger-hashimoto initialization):   1. copy from global to private 2. do private 3. copy from ...
    kbala
    last modified by kbala
  • Missing OpenCL CPU support under Windows

    On my system the (i think) most recent version of the AMD drivers (18.8.1, Windows 10 x64) no longer returns the CPU (FX-8350) as a valid OpenCL device.  Is this intended behavior or just a bug in my specific ins...
    pangea
    last modified by pangea