• OpenCL driver causing heap-corruption?

    Hi,   we have a severe issue with OpenCL and I wonder if anyone else has a similar problem, if this is a known AMD driver issue or if we are doing something wrong. We are using AMD Radeon RX 570 and 580 GPUs wit...
    ruwen
    last modified by ruwen
  • OpenCL Shader compiler had memory allocation problem

    I'm trying to compile a rather large kernel and being give the following error after 20-40 sec of kernel compile time, both in the runtime as well as under CodeXL:   Shader compiler had memory allocation problem...
    glupescu
    last modified by glupescu
  • OpenCL single memory allocation limit

    AMD OpenCL limits a single buffer allocation (CL_DEVICE_MAX_MEM_ALLOC_SIZE) to 50% of total memory.   So on a 8Gb card there is only 4Gb available for allocation in a single chunk.   This is very sad for ...
    octoboar
    last modified by octoboar
  • Strange printf behaviour on Vega

    Tested on latest 19.10.1 drivers. Windows 10 x64 1903 I attached cl file and cpp program which would launch this simple addVec kernel. Opencl code: #pragma OPENCL EXTENSION cl_amd_printf : enable __attribute__((req...
    ___
    last modified by ___
  • Feature request: expose newer AMD GCN / RDNA features as CL extension

    Back in the early days of OpenCL AMD added the famous cl_amd_media_ops (2) to expose hardware features to the programmers. Sadly with some of there more recent or more hidden hardware features like GDS or the cross la...
    lolliedieb
    last modified by lolliedieb
  • How to access more then 32k byte shared memory on Vega & Navi using Windows?

    Hi all. Well the title already describes it. I have got a code using 64k LDS on a Radeon VII and a RX 5700. Work group size is 1024. Its working fine on Ubuntu 16.04 and 18.04 using amdgpu-pro 18.50, 19.30 and ROCm ...
    lolliedieb
    last modified by lolliedieb
  • Offline compilation for gfx1010 crashes

    When I try to compile any OpenCL source for gfx1010, the test application crashes in one of the AMD driver DLLs. Tested with Adrenalin 19.7.1 and 19.7.3 on Windows 10 and Windows 7.   That's a crash report I am...
    timchist
    last modified by timchist
  • OpenCL: "AMD HSA Code Object loading failed" in clBuildProgram on AMD Radeon RX 5700 XT

    Hi,   Developer of PTGui here (www.ptgui.com).   One of the users of my software has reported an error while building OpenCL kernels on a Radeon RX 5700 XT on Windows 10. clBuildProgram returns "AMD HSA Co...
    joostn
    last modified by joostn
  • OpenCL memory synchronization issue on Radeon Pro WX9100

    Hi, the attached Program produces errors where it seems that some times writes to a buffer get ignored when run with a Radeon Pro WX9100, driver version 19.Q3.1 on Windows 10 x64 1809. The same Program runs without ...
    mierowsl
    last modified by mierowsl
  • Bug in OpenCL compiler

    I found a bug in OpenCL compiler in the latest drivers. At least it is persistent in Adrenalin 19.5.2 and 19.8.1. Minimal reproducing example is included in the file. It just multiplies several complex numbers in a lo...
    melirius
    last modified by melirius
  • Why not ship the latest OpenCL ICD Loader?

    In order to enumerate OpenCL platforms in a system, the ICD loader is usually the best option because it allows a platform independent way of having multiple OpenCL implementations in the same system.   The Rade...
    tluisrs
    last modified by tluisrs
  • clGgetDeviceIDs suddenly very slow

    We are currently developing an OpenCL application on Windows 10 (Visual Studio 2017) but have noticed that the OpenCL performance has recently degraded, with the call to clGetDeviceIDs now taking around 10 second...
    andyste1
    last modified by andyste1
  • Why I can't use buffers with 4GB?

    Hi, I'm using OpenCL on Windows 10 and a Radeon RX580 card (8GB VRAM). I tried to allocate two buffers with 4GB to use in a kernel, but at this size, all I get is 0.0. I double checked address bits and it is 64 and th...
    nightz85
    last modified by nightz85
  • Broken OpenCL drivers for RX5700

    Hello. I see many messages regarding wrong results that AMD RX 5700 cards producing. Those results are consistent (being WRONG) enough to pass statistical validation.   Why AMD being long-term and knowable corp...
    Raistmer
    last modified by Raistmer
  • Why does device's opencl version using cl2.hpp shows a opencl 1.2 device while the SDK has opencl 2.0?

    when I get the cl::device info with CL_DEVICE_VERSION flag it shows I have a gpu compatible with opencl1.2 but it is in fact opencl 2.0 (the platform shows it is compatible with 2.1 and the Fiji has support for OpenCL...
    pontiacgtx*
    last modified by pontiacgtx*
  • How to compile offline with LLVM-8 for AMDPAL

    Dear community,   I am planning to ship a software using binary kernels with inline asm. Therefore I decided to go with LLVM based offline compile, since the buildin pal compiler can not handle this. Hereby it i...
    lolliedieb
    last modified by lolliedieb
  • Offline compilation for gfx906 not possible on a VM

    We used to compile our OpenCL code on a virtual machine without an AMD GPU by extracting all DLL files from AMD driver to a folder in PATH. This worked fine until at least Catalyst 17.8.2 and allowed us to compile bin...
    timchist
    last modified by timchist
  • What the error "HSAIL doesn't support OpenCL extension spir" means?

    I am trying to use SPIR in Windows with the latest AMD Adrenalin 19.5.2, but since I upgraded to the latest version I'm getting this error in the call to clBuildProgramWithBinary   Error: HSAIL doesn't support Op...
    tluisrs
    last modified by tluisrs
  • clEnqueueAcquireD3D11ObjectsKHR blocks for a long time

    In my application, I have a processing thread that enqueues an OpenCL kernel that writes to a ID3D11Texture2D object.   Everything works fine in terms of correctness. I can successfully acquire the shared O...
    elad
    last modified by elad
  • OpenCL compiler SIGSEGV'ing

    Hello!   So I've been writhing my OpenCL project until I run into a strange problem: a call to clBuildProgram results in a segmentation fault.   I'm providing a sample code here (see attached archive) that...
    be_dos
    last modified by be_dos