• Segfault in clinfo

    Hi there, I've installed the ROCM runtime on my (Debian testing) machine (upstream kernel 5.3.14-1, dual-socket Haswell Xeon) following the instructions. When I run clinfo, I get a segfault. Adding "HSAKMT_DEBUG_LEVE...
    inducer77
    last modified by inducer77
  • Newcomer - Can I Get Whitelisted for OpenCL Forum?

    Hello AMD!   I'm having a problem where my new Radeon VII is not being detected by clinfo for OpenCL/compute jobs, while my RX 580 still is.   A helpful user replied and let me know I should probably ask t...
    makeitwork
    last modified by makeitwork
  • OpenCL on E8860 Linux

    I am having issues with running an OpenCL program on an E8860 and would like to ask for advice.   I am trying to get an OpenCL program to run on an E8860 on Linux, preferrably Centos 7  I have tried th...
    rt0218
    last modified by rt0218
  • Looking for Linux/Open CL2.0 Driver for AMD A10-9620P

    Does AMD have any kind of official support ?   Some how, I can not for the life of me find a working OpenCL ( I would like OpenCL 2.0 ) for Linux and my computer. Surely there is ? The question is where ?  ...
    scarfez
    last modified by scarfez
  • Current status of OpenCL for a SI (R7 370) in Linux

    Hi,   As I asked in Linux OpenCL not working AMDGPU-PRO (max global size 0, CL_OUT_OF_HOST_MEMORY), the problem persist.   I tried both in Arch and in Ubuntu 18.04. If I go for mesa + amdgpu open source dr...
    userxx
    last modified by userxx
  • E8860 do not  be identify in OpenCL

    Hi,      I have a X86 signal board computer(ADVANTECH MIC-6311,i7-4700EQ,HD Graphics 4600 ) and a E8860 GPU board.They are connected through PCIe.      My system is Win7 32bit...
    yyd1986
    last modified by yyd1986
  • Does OpenCL support latest APU in Linux environment?

    Dear All, I want to try OpenCL on AMD APU. I have a question.   Can OpenCL2.0 driver be installed on latest APU in Linux environment, such as A12-9800 APU and Ryzen 5 2400G in Ubuntu OS?   OpenCL 2.0 Driv...
    merlion
    last modified by merlion
  • Cannot Get OpenCL on Linux to Work At All

    I have a Vega 56. I downloaded the 17.50 driver, and installed it using: amdgpu-pro-install --compute   # rpm -qa | grep amdgpu | sort amdgpu-core-17.50-543815.el7.noarch amdgpu-dkms-17.50-543815.el7.noarch ...
    powerload
    last modified by powerload
  • Where do i download OpenCl 2.0 for AMD R-Series RX 421 BD Merlin Falcon ??

    Hello I'm trying to download openCl 2.0 for Ubuntu  but the following link is broken AMD OpenCL™ 2.0 Driver.  There is another way to get the installer ? I searched my boardcard on Download Drivers ...
    gpd
    last modified by gpd
  • How to get OpenCL 1.2 on Ubuntu 16.04 x86_64?

    I've found some conflicting information.   It seems OpenCL 1.2 is only possible on Ubuntu 14.04 (and you must downgrade the Linux kernel to 3.19): Recommended Open CL SDK for use with AMDGPU-PRO on Linux? ...
    markswanson
    last modified by markswanson
  • Recommended Open CL SDK for use with AMDGPU-PRO on Linux?

    Many web sites recommend AMD APP SDK for use with AMD GPUs, but I recently learnt that the most recent AMDGPU-PRO driver for Ubuntu 16.04 is incompatible with the AMD APP SDK. Question 1: What would be a suitable Open...
    drnil
    last modified by drnil