• Crash when using GL_ARB_bindless_texture on the latest drivers

    This appears to be a regression in the OpenGL drivers, possibly a recent one. It's the exact same issue as Crashes when using GL_ARB_bindless_texture with AMD drivers   Verified using the minimal repro...
    hgoel
    last modified by hgoel
  • Texture sampling is different on RX 5700 XT?

    Hello.   It looks like the RX 5700 XT with the latest driver (19.9.2, 19.9.3) do not react on texture LOD bias (GL_TEXTURE_LOD_BIAS) param. We have a number of GPUs, both AMD and Nvidia here in CI rack. Since we...
    a.devaykin
    last modified by a.devaykin
  • NoCompilerFound at memory location

    Hi guys, I am a game programmer using UE4, I am integrating Mali OpenGLES Emulator into UE4. After some modification, I met the situation that the shader cannot be compiled, it throw a exception in the dll of the emu...
    chenmo
    last modified by chenmo
  • Issue with glDrawBuffers when setting one of the entries to GL_NONE

    Hello,   I ran into an issue with glDrawBuffers and MRT when disabling certain buffers.   Consider this (simplified) fragment shader #version 150 core out vec4 Color0; out vec4 Color1; out vec4 Color2;...
    xtr3mer
    last modified by xtr3mer
  • Bug Report: "GL_ARB_conservative_depth" is not supported

    When using AMD Graphics Hardware, fragment shaders fail to compile when using the GL_ARB_conservative_depth extension although the extension is advertised as supported by the driver.   I encounter this error on ...
    nirei
    last modified by nirei
  • Matching Vulkan and OpenGL device UUID

    Hello.   I'm having troubles with picking correct device for Vulkan-OpenGL interop. On our PCs with AMD cards, OpenGLreports slightly different device UUID than Vulkan does. I use the following code to get Open...
    a.devaykin
    last modified by a.devaykin
  • Radeon RX 480 driver performance issues and bugs, OpenGL, Vulkan, DirectX, Mantle

    Hi everyone, my name is Jacques   I was supposed to post in "OpenGL & Vulkan" as suggested by developer xhuang, but since I am a newcomer I am only allowed to post here. I am having performance and bug issu...
    hitbm47
    last modified by hitbm47
  • SQUAD Unreal Engine 4 driver issues?

    Hi everyone, a few people on the Graphics forum has notified me of struggling with performance issues with Radeon drivers in Unreal Engine 4 games such as squad.   I would just like to share it on the driver dev...
    hitbm47
    last modified by hitbm47
  • Standard Elder Scrolls of Skyrim low GPU usage and low FPS issues on RX 480

    Hi everyone,   Here are my specs, Windows 10 Professional 64-bit (up to date) 16GB (8x2) HyperX Fury DDR3 1866Mhz RAM AMD FX 8350 stock clocks MSI Radeon RX 480 Gaming X 8G (19.5.1) MSI 990FXA Motherboard (...
    hitbm47
    last modified by hitbm47
  • SPIR-V compiler fails to build valid shader

    The attached SPIR-V vertex module fails to build on AMD's proprietary drivers and in RGA's offline compiler. To reproduce grab that file (in its binary or text form) into RGA as a vertex shader and attempt to build it...
    rodrigoloc
    last modified by rodrigoloc
  • glGetInteger64v(GL_TIMESTAMP, ...) still broken on Vega

    In old drivers there was a bug in getting the current GPU time on Vega GPUs, as described also here: glGetInteger64v(GL_TIMESTAMP, ...) broken on Vega    This was fixed in later drivers, but the behavior i...
    cameni
    last modified by cameni
  • Interop of Vulkan Image and D3D11 Texture

    I am trying to figure out how to create a Vulkan 2D image shared with D3D11 texture.   My Windows 10 development system is equipped with Radeon RX 570 Series card which is a primary GPU device with monitors...
    roman380
    last modified by roman380
  • Bug report: experiencing an Access Violation error with a particular compute shader, but only on amd adapter, not WARP.

    I've found that with some shaders, the ID3D11Device::CreateComputeShader function causes an access violation when the ID3D11Device in question is created with an AMD adapter.  I've been able to repro this co...
    gfmatt
    last modified by gfmatt
  • Does Radeon Chill work accurately with vertical retrace?

    Hi everyone   I would please like some clarity on this subject, I like setting Chill Min = Chill Max = 60FPS or setting Chill Min = Chill Max = 30FPS because it provides less input delay even when in-game VSync ...
    hitbm47
    created by hitbm47
  • Radeon RX 480 serious stutter/hitching in Far Cry 3, theHunter: Call of the Wild?

    Hi everyone, current config: -Windows 10 Pro 64-bit, build 18362 or version 1903 -Radeon RX 480 8G -GTX 1060 3GB -MSI B450 Tomahawk -Ryzen 5 1600 -2x 8GB DDR 4 2666Mhz RAM   Please note, this has existed b...
    hitbm47
    last modified by hitbm47
  • FE_INVALID after call to vkCreateInstance

    Hi,   After upgrading my radeon software from 16.10.1 to 17.7.1 (Crimson ReLive) I started detecting an FE_INVALID floating point exception in my application. This seems to be triggered by calling vkCreateInstan...
    nythrix
    last modified by nythrix
  • Will RX 480 Support Fragment Shader Interlock? GL & VK

    Vulkan 1.1.110 Released  will RX 480 support the following extensions anytime soon? VK_EXT_fragment_shader_interlock - Featured in Vulkan 1.1.110 GL_ARB_fragment_shader_interlock - Part of OpenGL 4.5  ...
    onsolight
    last modified by onsolight
  • Will Vega support Vulkan 1.1.110?

    Hi there can I please request driver support for VK_EXT_fragment_shader_interlock.  Vega has the capability under DirectX (rasterizer ordered views), however the feature is missing under Vulkan and OpenGL 4.6 cor...
    gharland
    last modified by gharland
  • vkCreateGraphicsPipelines returns VK_ERROR_INITIALIZATION_FAILED

    Hi All ! I use glslang tool for compilation GLSL/HLSL to SPIR-V.   We have two identical HLSL and GLSL vertex shaders. vkCreateGraphicsPipelines returns VK_ERROR_INITIALIZATION_FAILED, if I use SPIR-V code from...
    Andrey2007AMD
    last modified by Andrey2007AMD
  • GPU driver hang

    I have a Vulkan issue that only seems to occur on my GPU. I have thus tested it on an R9 Nano, an Nvidia 1060, and it works fine. Validation layers only produce errors related to texture layouts which worked previousl...
    dutta
    last modified by dutta