• vkCmdExecuteCommands messes up primitive topology

    The problem seems to be Vega-specific (reproed on Vega 64, 20.2.2). On the R7 360 as well as on other cards it works correctly.   The sample in a nutshell is: record secondary command buffers wrt. the current v...
    asylum29
    last modified by asylum29
  • Rendering to a TextureView broken?

    There is a one year old question here with no repro case attached and no resolution. I've commented there about two months ago to provide a repro case, but no reaction followed. I'll ask it in a new question then. ...
    a.devaykin
    created by a.devaykin
  • SPIR-V shader on AMD GPU

    I tried latest AMD gpu driver. But my SPIR-V program doesn't work.   fbo_ubo: This program use uniform block object. SPIR-V route doesn't work correctly. I think GPU can not receive the data of uniform block. It...
    marzRX
    created by marzRX
  • Does Radeon Chill Max break for other Radeon users as well?

    Dear readers   My currents specifications: -Windows 10 64 bit, build 18362.836 (version 1903) -16 GB DDR4 RAM - Ryzen 5 1600 - MSI Tomahawk B450 - Radeon RX 480 Gaming X 8G (20.4.2)   I would like to ...
    hitbm47
    last modified by hitbm47
  • Can AMD give us a feature/guide to have smooth & tearless 30FPS or half-refresh Enhanced Sync?

    Hi AMD   Radeon Chill has great input-response, but I would just like to report, here as well, that it breaks/disables momentarily in quite a few games when looking at less demanding areas, thus causing game phy...
    hitbm47
    last modified by hitbm47
  • Vulkan: Working with Mixed GPU rendering?

    I read that DirectX 12 supports explicit Multi-GPU support, and I am wanting to find out how to handle Explicit multi-gpu using Vulkan. I am needing explicit Multi-GPU because I have mixed graphics cards where all of ...
    kphillisjr
    last modified by kphillisjr
  • AMD Driver Bug: Vulkan pipeline creation fails with multi entry-point SPIR-V modules

    Attached are two SPIR-V modules (I have more which reproduce this, in case it becomes necessary), that when used to create a graphics pipeline cause vkCreateGraphicsPipelines to fail with a generic "VK_ERROR_OUT_OF_HO...
    crosire
    last modified by crosire
  • OpenGL ARB_sparse_texture (Driver crash, texture issues)

    Currently we (PCSX2 Team) are trying to implement Sparse Texture support and seem to have stumbled on to several issues on AMD cards which are not present at all on Nvidia (tested by several people).   Major iss...
    lightningterror
    last modified by lightningterror
  • Strange compute shader behavior[solved; it was a goof on my part]

    I was writing a scan over an array of numbers with the use of subgroup operations(targeting Vk 1.2 and SPIR-V 1.5) and noticed something I can only classify as "extremely suspicious". #version 460 #extension GL_KHR_s...
    kknewkles
    last modified by kknewkles
  • Vulkan loading/compiling SPIRV in AMD Driver use too much RAM

    Short: 1. download this vk_spirv_mem.zip 2. open vk_spirv_mem.zip\vk_spirv_mem\shaders\spv\buf.frag.spv in Radeon GPU Analyzer (RGA) 3. look on RAM usage in Windows Task Manager, I have ~5.2Gb RAM us...
    danilw
    last modified by danilw
  • glPointSize has no effect...

    Issue with glPointSize, which does not appear to affect the displayed point size. The point is always displayed with size 1.   Background: Developing a program which displays some sort of drawing, using Ope...
    naveen.metamation
    last modified by naveen.metamation
  • Issues with ARB_gl_spirv

    With AMD on Windows SPIR-V shaders in OpenGL don't seem to work properly. I encountered issues where nothing is rendered at all and others seem to have similar issues (How to Load SPIR-V Shaders in OpenGL | Geeks3D...
    waylan
    last modified by waylan
  • AMD Radeon HD 5700 Series OpenGL Driver Issues

    Hey guys, I'm working on some OpenGL code and I noticed some peculiarities on one of my machines which don't happen on any of the other ones. After messing around with my code I managed to get it working but I have no...
    cryru
    last modified by cryru
  • vkEnumeratePhysicalDevices no longer returns primary GPU as the first physical device

    After recent driver update I noticed change in behavior of vkEnumeratePhysicalDevices, which no longer returns primary GPU as first in the list. This change seems to manifest since one of 20.1.X driver updates. This h...
    Deluxe
    last modified by Deluxe
  • Looking For Old D3D8 Source Code(s)

    I am trying to find some old demos/source code from ATI/AMD back in the Direct3D8 days. The specific file I would love to find was located at: http://www.ati.com/na/pages/resource_centre/dev_rel/samples/TreasureChes...
    atom0s
    last modified by atom0s
  • glDrawElements caused null reference in libMaliEmulator.dll

    Hi guys, I am integrating Mali ES Emulator into UE4. After some modification it can run, but caused a null reference. Here is the stack: ->nvoglv64.dll!000000005116a090() Unknown    nvoglv64.dl...
    chenmo
    last modified by chenmo
  • Crash when using GL_ARB_bindless_texture on the latest drivers

    This appears to be a regression in the OpenGL drivers, possibly a recent one. It's the exact same issue as Crashes when using GL_ARB_bindless_texture with AMD drivers   Verified using the minimal repro...
    hgoel
    last modified by hgoel
  • Texture sampling is different on RX 5700 XT?

    Hello.   It looks like the RX 5700 XT with the latest driver (19.9.2, 19.9.3) do not react on texture LOD bias (GL_TEXTURE_LOD_BIAS) param. We have a number of GPUs, both AMD and Nvidia here in CI rack. Since we...
    a.devaykin
    last modified by a.devaykin
  • NoCompilerFound at memory location

    Hi guys, I am a game programmer using UE4, I am integrating Mali OpenGLES Emulator into UE4. After some modification, I met the situation that the shader cannot be compiled, it throw a exception in the dll of the emu...
    chenmo
    last modified by chenmo
  • Issue with glDrawBuffers when setting one of the entries to GL_NONE

    Hello,   I ran into an issue with glDrawBuffers and MRT when disabling certain buffers.   Consider this (simplified) fragment shader #version 150 core out vec4 Color0; out vec4 Color1; out vec4 Color2;...
    xtr3mer
    last modified by xtr3mer