• Strange compute shader behavior[solved; it was a goof on my part]

    I was writing a scan over an array of numbers with the use of subgroup operations(targeting Vk 1.2 and SPIR-V 1.5) and noticed something I can only classify as "extremely suspicious". #version 460 #extension GL_KHR_s...
    kknewkles
    last modified by kknewkles
  • Vulkan loading/compiling SPIRV in AMD Driver use too much RAM

    Short: 1. download this vk_spirv_mem.zip 2. open vk_spirv_mem.zip\vk_spirv_mem\shaders\spv\buf.frag.spv in Radeon GPU Analyzer (RGA) 3. look on RAM usage in Windows Task Manager, I have ~5.2Gb RAM us...
    danilw
    last modified by danilw
  • AMD Vulkan driver SPIR-V shader Much more critical bug

    This is my third bugreport about Vulkan SPIR-V shaders bugs in AMD: Previous bugs 1, 2   Hardware AMD Vega 8(Ryzen 3200) This is not hardware bug, why - because this shader work without problems in same AMD ha...
    danilw
    last modified by danilw
  • glPointSize has no effect...

    Issue with glPointSize, which does not appear to affect the displayed point size. The point is always displayed with size 1.   Background: Developing a program which displays some sort of drawing, using Ope...
    naveen.metamation
    last modified by naveen.metamation
  • AMD 5700XT OpenGL Driver Bug

    Hi,   When using an AMD 5700XT and trying to run an OpenGL application i get a driver crash in the following line:   glDrawArraysInstanced(GL_PATCHES, 0, static_cast <GLsizei>(4), static_cast <GLs...
    aferreira.bs@gmail.com
    last modified by aferreira.bs@gmail.com
  • AMD Radeon HD 5700 Series OpenGL Driver Issues

    Hey guys, I'm working on some OpenGL code and I noticed some peculiarities on one of my machines which don't happen on any of the other ones. After messing around with my code I managed to get it working but I have no...
    cryru
    last modified by cryru
  • AMD Vulkan driver SPIR-V shader Very critical bug

    hardware AMD Vega 8   1. This is not hardware bug, why - because this shader work without problems in same AMD hardware in OpenGL. 2. This bug does ruin all if/else/for loops/etc inside of loops and this can no...
    danilw
    last modified by danilw
  • vkEnumeratePhysicalDevices no longer returns primary GPU as the first physical device

    After recent driver update I noticed change in behavior of vkEnumeratePhysicalDevices, which no longer returns primary GPU as first in the list. This change seems to manifest since one of 20.1.X driver updates. This h...
    Deluxe
    last modified by Deluxe
  • Looking For Old D3D8 Source Code(s)

    I am trying to find some old demos/source code from ATI/AMD back in the Direct3D8 days. The specific file I would love to find was located at: http://www.ati.com/na/pages/resource_centre/dev_rel/samples/TreasureChes...
    atom0s
    last modified by atom0s
  • AMD GLES2 Depth write broken

    related to Godot engine (my bugreport there) link image of broken depth      test project GLES2 link(exe) depth on GLES3 does not have this bug test project GLES3 link(exe)   Windows 10, AMD ...
    danilw
    created by danilw
  • glDrawElements caused null reference in libMaliEmulator.dll

    Hi guys, I am integrating Mali ES Emulator into UE4. After some modification it can run, but caused a null reference. Here is the stack: ->nvoglv64.dll!000000005116a090() Unknown    nvoglv64.dl...
    chenmo
    last modified by chenmo
  • Crash when using GL_ARB_bindless_texture on the latest drivers

    This appears to be a regression in the OpenGL drivers, possibly a recent one. It's the exact same issue as Crashes when using GL_ARB_bindless_texture with AMD drivers   Verified using the minimal repro...
    hgoel
    last modified by hgoel
  • Texture sampling is different on RX 5700 XT?

    Hello.   It looks like the RX 5700 XT with the latest driver (19.9.2, 19.9.3) do not react on texture LOD bias (GL_TEXTURE_LOD_BIAS) param. We have a number of GPUs, both AMD and Nvidia here in CI rack. Since we...
    a.devaykin
    last modified by a.devaykin
  • NoCompilerFound at memory location

    Hi guys, I am a game programmer using UE4, I am integrating Mali OpenGLES Emulator into UE4. After some modification, I met the situation that the shader cannot be compiled, it throw a exception in the dll of the emu...
    chenmo
    last modified by chenmo
  • Issue with glDrawBuffers when setting one of the entries to GL_NONE

    Hello,   I ran into an issue with glDrawBuffers and MRT when disabling certain buffers.   Consider this (simplified) fragment shader #version 150 core out vec4 Color0; out vec4 Color1; out vec4 Color2;...
    xtr3mer
    last modified by xtr3mer
  • OpenGL completely broken by Adrenalin 2020 driver

    I work on the RPCS3 emulator and since the new driver came out, OpenGL no longer works. This doesn't seem isolated to the application as replaying traces on affected hardware causes replay applications like renderdoc ...
    kd-11
    last modified by kd-11
  • How the VK_LAYER_AMD_switchable_graphics is supposed to work?

    I have a laptop with Intel 620 and extenal RX 580 in Akitio Node Thunderbolt 3 case. When connecting eGPU and running vulkaininfo only the Intel 620 gpu is enumerated and then I get an error: vulkaninfo.h:881: fa...
    cospp
    last modified by cospp
  • Vulkan development and recent AMD drivers

    I've recently purchased an RX 470(Asus mining edition) to get access to AMD's suite of awesome profiling tools, for Vulkan development. Alas, under Adrenalin 19.12.2(and I've installed the optional 19.12.3 today), Vu...
    kknewkles
    last modified by kknewkles
  • Awful OpenGL FBO performance when writing to nonzero attachment

    I'm making a game graphics engine with some screen-space processing (that's important), and figured out that our game runs incredibly slow on AMD gpus.   Investigation showed that the problem is in writing to no...
    s_k
    last modified by s_k
  • Bug Report: "GL_ARB_conservative_depth" is not supported

    When using AMD Graphics Hardware, fragment shaders fail to compile when using the GL_ARB_conservative_depth extension although the extension is advertised as supported by the driver.   I encounter this error on ...
    nirei
    last modified by nirei